<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="https://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">

    <head profile="https://gmpg.org/xfn/11">

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

        <meta name="viewport" content="width=device-width, initial-scale=1.0" />

        
        <link rel="shortcut icon" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/favicon.ico" type="image/x-icon" />

        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Chivo" />

        	    <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/styles-ed7df33623f4cc295e040dfd55d6f38c.css" type="text/css" />

        <!--[if IE 7]>
        <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/style_ie7.css" type="text/css" />
        <![endif]-->

        <!--[if gte IE 8]>
        <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/style_ie8.css" type="text/css" />
        <![endif]-->

        <link rel="pingback" href="https://www.legitreviews.com/xmlrpc.php" />

                    <link rel="image_src" type="image/jpeg" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/default_like.jpg" />
            


        <script type="text/javascript">
            (function() {
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            })();
        </script>

        
        
<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The custom AMD Radeon XT 6800 XT graphics cards launched this week and the very first card to be delivered is the XFX Speedster MERC319 Radeon RX 6800XT. We found that the AMD Radeon RX 6800 XT was no joke in our launch article, but this card is truly next level."/>
<meta name="news_keywords" content="merc319, xfx, technology, computing" />
<meta name="original-source" content="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923" />
<link rel="canonical" href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923" />
<link rel="next" href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/2" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="XFX Speedster MERC319 Radeon RX 6800 XT Review - Legit Reviews" />
<meta property="og:description" content="The custom AMD Radeon XT 6800 XT graphics cards launched this week and the very first card to be delivered is the XFX Speedster MERC319 Radeon RX 6800XT. We found that the AMD Radeon RX 6800 XT was no joke in our launch article, but this card is truly next level." />
<meta property="og:url" content="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923" />
<meta property="og:site_name" content="Legit Reviews" />
<meta property="article:tag" content="MERC319" />
<meta property="article:tag" content="xfx" />
<meta property="article:section" content="Video Cards" />
<meta property="article:published_time" content="2020-11-27T23:00:55+00:00" />
<meta property="article:modified_time" content="2020-11-27T23:17:09+00:00" />
<meta property="og:updated_time" content="2020-11-27T23:17:09+00:00" />
<meta property="og:image" content="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle.jpg" />
<meta property="og:image:secure_url" content="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle.jpg" />
<meta property="og:image:width" content="1100" />
<meta property="og:image:height" content="653" />
<meta property="og:image:alt" content="XFX Speedster MERC319 Radeon RX 6800 XT" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; Feed" href="https://www.legitreviews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; Comments Feed" href="https://www.legitreviews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; XFX Speedster MERC319 Radeon RX 6800 XT Review Comments Feed" href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.legitreviews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='https://api.w.org/' href='https://www.legitreviews.com/wp-json/' />
<link rel='shortlink' href='https://www.legitreviews.com/?p=223923' />
<link rel="alternate" type="application/json+oembed" href="https://www.legitreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923" />
<link rel="alternate" type="text/xml+oembed" href="https://www.legitreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/4042371/Top_Leaderboard_Banner', [728,90], "acm-ad-tag-Top_Leaderboard_Banner").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right_Top_Half_Page', [300,600], "acm-ad-tag-Right_Top_Half_Page").addService(googletag.pubads());
googletag.defineSlot('/4042371/Left-Skyscraper-Above', [160,600], "acm-ad-tag-Left-Skyscraper-Above").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right-Skyscraper-Above', [160,600], "acm-ad-tag-Right-Skyscraper-Above").addService(googletag.pubads());
googletag.defineSlot('/4042371/Left-Skyscraper-Below', [160,600], "acm-ad-tag-Left-Skyscraper-Below").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right-Skyscraper-Below', [160,600], "acm-ad-tag-Right-Skyscraper-Below").addService(googletag.pubads());
googletag.defineSlot('/4042371/Site-Wallpaper', [1,1], "acm-ad-tag-Site-Wallpaper").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

        
        <title>
            XFX Speedster MERC319 Radeon RX 6800 XT Review - Legit ReviewsXFX Speedster MERC319 Radeon RX 6800 XT        </title>

    </head>

    <body class="post-template-default single single-post postid-223923 single-format-standard">
        <div id="wrapper">
        <div id="page-wrap">

            <div id="header">
                <a href="https://www.legitreviews.com" id="logo" class="ir">&nbsp;</a>

                <div id="header-banner">
                                    </div>
                <div class="clear"></div>

	            <div class="main-navigation" role="navigation">

		            <button type="button" class="main-navigation__toggle js-main-navigation-toggle" aria-hidden="true" aria-owns="main-navigation__container" aria-controls="main-navigation__container" aria-haspopup="true" aria-label="Navigation Toggle" aria-pressed="false"></button>

		            <div id="main-navigation__container" class="main-navigation__container js-main-navigation" aria-hidden="false" tabindex="0">

	                <div id="header-menu" class="menu-header-categories-menu-container"><ul id="menu-header-categories-menu" class="main-menu-header"><li id="menu-item-22140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22140"><a href="https://www.legitreviews.com/processors">Processors</a></li>
<li id="menu-item-22139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22139"><a href="https://www.legitreviews.com/pc-cases">PC Cases</a></li>
<li id="menu-item-22142" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22142"><a href="https://www.legitreviews.com/video-cards">Video Cards</a></li>
<li id="menu-item-22137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22137"><a href="https://www.legitreviews.com/motherboards">Motherboards</a></li>
<li id="menu-item-22141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22141"><a href="https://www.legitreviews.com/storage">Storage</a></li>
<li id="menu-item-22136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22136"><a href="https://www.legitreviews.com/mobile">Mobile</a></li>
<li id="menu-item-22134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22134"><a href="https://www.legitreviews.com/memory">Memory</a></li>
<li id="menu-item-22133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22133"><a href="https://www.legitreviews.com/cooling">Cooling</a></li>
<li id="menu-item-22135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22135"><a href="https://www.legitreviews.com/misc">Misc</a></li>
<li id="menu-item-22138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22138"><a href="https://www.legitreviews.com/news">News</a></li>
</ul></div>
	                <div class="clear"></div>

		                <div id="header-submenu">
		                    <ul>
		                        <li><a href="https://www.legitreviews.com" class="submenu-home submenu-a">Home</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://forums.legitreviews.com/" class="submenu-forum submenu-a" >Forum</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://amzn.to/2zbZTs5" class="submenu-shop submenu-a" >Shop</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://www.legitreviews.com/feed" class="submenu-rss submenu-a" >RSS</a></li>
		                    </ul>
		                </div><!-- end header-submenu-->

		            </div><!-- .main-navigation__container -->

	            </div><!-- .main-navigation -->

	            <div class="header-submenu-search">
                    <form method="get" id="searchform" name="searchform" action="https://www.legitreviews.com/gsearch">
                        <input type="text" name="q" id="gs" class="search-input" placeholder="Search Legit Reviews" />
                        <button type="submit" id="searchsubmit" form="searchform"><span class="search-button__icon ir">Search</span></button>
                        <!-- <input type="image" id="searchsubmit" src="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/search_btn.png" alt="Search" /> -->
                    </form>
                </div>

                <div class="clear"></div>
            </div><!-- end header -->
            <div id="main-wraper">

<div class="main">

  <div class="breadcrumbs">
    <!-- Breadcrumb NavXT 6.2.1 -->
<a title="Go to Legit Reviews." href="https://www.legitreviews.com">Legit Reviews</a><span class="bredcrumbs-sep">&nbsp;</span><span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Reviews category archives." href="https://www.legitreviews.com/reviews" class="taxonomy category"><span property="name">Reviews</span></a><meta property="position" content="2"></span><span class="bredcrumbs-sep">&nbsp;</span>XFX Speedster MERC319 Radeon RX 6800 XT Review  </div>
  <div class="sub-main ">

          <h2>XFX Speedster MERC319 Radeon RX 6800 XT Review</h2>
      
      <div class="main-content-article-author-single">
        Posted by <span class="author-span">Nathan Kirsch</span>
        <span class="header-submenu-table-sep">|</span> Fri, Nov 27, 2020 - 5:00 PM
        
      </div>

      <div style="clear:both"></div>

              <div class="single-pagination-wrap">
          <span class="jump-to">Jump To:</span>
          <select onchange="location.href=this.value">
          <option value="" selected="selected">Page 1: XFX Speedster MERC319 Radeon RX 6800 XT</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/2">Page 2: Test System</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/3">Page 3: Borderlands 3</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/4">Page 4: Tom Clancy's Rainbow Six Siege</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/5">Page 5: Total War: Three Kingdoms</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/6">Page 6: 3DMark Tests Galore!</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/7">Page 7: VRMark &amp; Superposition</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/8">Page 8: Boundary Benchmark &amp; Basemark</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/9">Page 9: Temperature &amp; Power Consumption</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/10">Page 10: Final Thoughts and Conclusions</option>
          </select>
        </div><!-- end single-pagination-wrap -->
        <div class="clear"></div>
              <div class="main-content-article-div">
        <div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_20 addtoany_list" data-a2a-url="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923" data-a2a-title="XFX Speedster MERC319 Radeon RX 6800 XT Review"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.legitreviews.com%2Fxfx-speedster-merc319-radeon-rx-6800-xt-review_223923&amp;linkname=XFX%20Speedster%20MERC319%20Radeon%20RX%206800%20XT%20Review" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p><!--pagetitle:XFX Speedster MERC319 Radeon RX 6800 XT--></p>
<h3>XFX Speedster MERC319 Radeon RX 6800 XT</h3>
<p>The custom AMD Radeon XT 6800 XT graphics cards launched this week and the very first card to be delivered is the XFX Speedster MERC319 Radeon RX 6800XT. We found that the AMD Radeon RX 6800 XT was no joke in our launch article, but we&#8217;ve been told by AMD&#8217;s board partner that their custom cards truly next level. The Speedster MERC319 Radeon RX 6800 XT is the flagship model for XFX and commands a paltry $799 (<a href="https://amzn.to/2HIkux5" target="_blank" rel="nofollow noopener">buy on Amazon</a>) for those that think they are worthy of owning one. This card is nothing like the AMD Radeon RX 6800 XT reference cards that came to market last week at $649 to do battle with the NVIDIA GeForce RTX 3080 that is priced at $699.</p>
<p>So, without further ado lets dive in and take a look at the XFX Speedster MERC319 Radeon RX 6800 XT.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT.jpg"><img class="aligncenter size-large wp-image-223935" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-645x921.jpg" alt="XFX Speedster MERC319 Radeon RX 6800XT" width="645" height="921" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-645x921.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-140x200.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-300x428.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-768x1096.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-195x278.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT.jpg 800w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The Speedster series is all about delivering ultra-high frame rates for gamers and is a new series of graphics cards by XFX. Get used to seeing more Speedster series cards from XFX as AMD introduces more Navi based GPUs. XFX Speedster MERC319 Radeon RX 6800XT is a pretty long name and XFX let us know that MERC stands for Mercury (not mercenary) and 319 relates to fan configuration used on the GPU cooler. 3 = Number of Fans, 1 = 100mm, 9 = 90mm. If XFX was to release a 2 fan model down the road with 2x 100mm fans the number would be MERC210.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box.jpg"><img class="aligncenter size-large wp-image-223934" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-645x425.jpg" alt="XFX Speedster MERC319 Radeon RX 6800XT" width="645" height="425" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-645x425.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-140x92.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-300x198.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-768x506.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box-195x129.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Box.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>Inside the box you&#8217;ll discover that the XFX Mercury 319 comes in a plastic bag and then has protective film over the front, back and top of the card to protect it from scratches while being installed. You also get a booklet that covers the warranty and installation as well as a piece of paper letting you know that you need to download the latest video card drivers from the internet.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle.jpg"><img class="aligncenter size-large wp-image-223928" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-645x383.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT Front" width="645" height="383" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-645x383.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-140x83.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-300x178.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-768x456.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle-195x116.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Angle.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The XFX Speedster MERC319 Radeon RX 6800 XT is a massive graphics card that stands 5.47-inches in height and 13.39-inches in length. It also takes up the Ghost Thermal design with a triple fan configuration. The two outer fans are 100mm (96mm blade) and then the middle axial fan is smaller at 92mm (88mm blade). These are from a new fan supplier, so this is the first time that these 13-blade dual ball bearing fans have been used by XFX.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2.jpg"><img class="aligncenter size-large wp-image-223925" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-645x389.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT with reference card" width="645" height="389" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-645x389.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-140x85.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-300x181.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-768x464.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2-195x118.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card2.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card.jpg"><img class="aligncenter size-large wp-image-223926" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-645x477.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT with reference card" width="645" height="477" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-645x477.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-140x103.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-300x222.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-768x568.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card-195x144.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-With-Reference-Card.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>To get an idea of just how large this card is here is the XFX Speedster MERC319 6800 XT next to the reference card by AMD.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front.jpg"><img class="aligncenter size-large wp-image-223933" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-645x280.jpg" alt="XFX Speedster MERC319 Radeon RX 6800XT Front" width="645" height="280" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-645x280.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-140x61.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-300x130.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-768x333.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front-195x85.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Front.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The last generation Thicc cards from XFX were good looking and it seems the Speedster cards don&#8217;t skip a beat.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back.jpg"><img class="aligncenter size-large wp-image-223931" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-645x288.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT Back" width="645" height="288" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-645x288.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-140x62.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-300x134.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-768x343.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back-195x87.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Back.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>XFX went with a full coverage metal backplate on this card and it looks great. It has XFX cut into the backplate and then across the left side &#8220;MERC&#8221; is printed on. You can see that there is also a cut out to the right of the card for passthrough airflow that feels similar to what NVIDIA introduced with the GeForce RTX-Series cards in the Founders Edition series.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top.jpg"><img class="aligncenter size-large wp-image-223932" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-645x202.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT Top" width="645" height="202" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-645x202.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-140x44.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-300x94.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-768x240.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top-195x61.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Top.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The top edge of this card is pretty busy looking thanks to all &#8216;layers&#8217; that wrap around the card. The big things to mention here is that you have Radeon RX 6800 XT that is backlit and then off to the far right the XFX logo is also backlit. All the backlighting is white with the exception of red &#8216;RX&#8217; and it looks sharp in a case. The colors aren&#8217;t changeable from what we understand.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS.jpg"><img class="aligncenter size-large wp-image-223938" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-645x505.jpg" alt="XFX Speedster MERC319 Radeon RX 6800XT Dual BIOS Switch" width="645" height="505" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-645x505.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-140x110.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-300x235.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-768x602.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS-195x153.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-DualBIOS.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>To the left of the two 8-pin PCIe power connecters is a BIOS switch that always to switch between the balanced BIOS and the Hardware Rage BIOS. The factory default setting is with the card set to Balanced BIOS (281 Watts) and this has the base clock at 1900MHz, game clock at 2090MHz and boost clock at up to 2340MHz. Those that bought this card for the ultimate gaming experience can flip the switch over to the left for the Rage BIOS (289 Watts) and this puts the base clock at 1925MHz, game clock at 2110MHz and boost clock at up to 2360MHz.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios.png"><img class="aligncenter size-large wp-image-223937" src="https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-645x200.png" alt="merc319 dual bios" width="645" height="200" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-645x200.png 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-140x43.png 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-300x93.png 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-768x238.png 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios-195x60.png 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/merc319-dualbios.png 777w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>Within each BIOS are 3 tuning presets that can be configured with AMD&#8217;s Adrenaline software. The default setting is balanced mode, but you can change that to quiet or rage if that is desired. Adjusting this setting will change the power limit of the card, fan target temperature junction and fan target speed. For our testing we&#8217;ll be enabling the Hardware Rage BIOS with the Adrenaline Rage setting set to Rage as well.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom.jpg"><img class="aligncenter size-large wp-image-223930" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-645x139.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT Bottom" width="645" height="139" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-645x139.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-140x30.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-300x65.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-768x165.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom-195x42.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Bottom.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The MERX319 6800 XT has 20 thermal pads that are used on the front and back of the card to ensure the cards thermal performance is on point! You can see some of them in the image above while looking at the bottom of the card.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End.jpg"><img class="aligncenter size-large wp-image-223929" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-645x405.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT End" width="645" height="405" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-645x405.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-140x88.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-300x188.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-768x482.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End-195x122.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-End.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>Looking at the end of the MERX319 6800 XT reveals 5 of the 7 6mm heatpipes that are used by the GPU cooler. If you add up the lengths of all seven heatpipes on this card it totals 1986.1mm or 6.51 feet of piping!</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb.jpg"><img class="aligncenter size-large wp-image-224018" src="https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-645x493.jpg" alt="" width="645" height="493" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-645x493.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-140x107.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-300x229.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-768x587.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb-195x149.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/xfx-merc319-6800xt-pcb.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>XFX is using a massive 2mm thick copper cold plate that measures 99mm x 85mm over the NAVI GPU. This makes direct contact with the GPU, but thermal pads are used between it and the cards 16GB of GDDR6 memory chips.</p>
<p>A beefy 14+2 power phase design was used for the MERC319 and that is a bump up from the reference designs 10+2 power phase design. XFX went with an Infineon XDPE132G5D 16-phase VRM controller and IR TDA21472 DrMOS chips.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors.jpg"><img class="aligncenter size-large wp-image-223927" src="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-645x382.jpg" alt="XFX Speedster MERC319 Radeon RX 6800 XT Display Connectors" width="645" height="382" srcset="https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-645x382.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-140x83.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-300x178.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-768x455.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors-195x115.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/11/XFX-Speedster-MERC319-Radeon-RX-6800XT-Display-Connectors.jpg 1100w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>When it comes to display connections you have the same display outputs as the 6800 XT reference model, with 2 DisplayPort, 1 HDMI 2.0 and a USB-C port that can be used with displays and compatible VR headsets.</p>
<p>Let&#8217;s move along to the test system and get to the benchmarks!</p>
                <div class="clear"></div>

                  <div class="single-pagination-wrap">
            <span class="jump-to">Jump To:</span>
            <select onchange="location.href=this.value">
            <option value="" selected="selected">Page 1: XFX Speedster MERC319 Radeon RX 6800 XT</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/2">Page 2: Test System</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/3">Page 3: Borderlands 3</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/4">Page 4: Tom Clancy's Rainbow Six Siege</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/5">Page 5: Total War: Three Kingdoms</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/6">Page 6: 3DMark Tests Galore!</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/7">Page 7: VRMark &amp; Superposition</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/8">Page 8: Boundary Benchmark &amp; Basemark</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/9">Page 9: Temperature &amp; Power Consumption</option>
<option value="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/10">Page 10: Final Thoughts and Conclusions</option>
            </select>
          </div><!-- end single-pagination-wrap -->
          <div class="clear"></div>
          <div class="single-pagination-numbers jump-bottom"> <span class="pag-text">1</span> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/2"><span class="pag-text">2</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/3"><span class="pag-text">3</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/4"><span class="pag-text">4</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/5"><span class="pag-text">5</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/6"><span class="pag-text">6</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/7"><span class="pag-text">7</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/8"><span class="pag-text">8</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/9"><span class="pag-text">9</span></a> <a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/10"><span class="pag-text">10</span></a>&nbsp<a href="https://www.legitreviews.com/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923/2"><span class="pag-text"> Next &raquo;</span></a></div>
        <div class="clear" style="height: 10px;"></div>

        <div id="amzn-assoc-ad-9f0a4c64-a478-47df-ac7f-057273f04ab3"></div>
        <script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=9f0a4c64-a478-47df-ac7f-057273f04ab3"></script>

      </div>
    
  </div><!-- end sub-main -->

  <div id="comments">
<div id="disqus_thread"></div>
</div>

  
</div><!-- end main -->

<div id="sidebar">

        
    <div id="SidebarWidgetOne">
        </div>

    <div id="twitter-box">
        <a class="twitter-timeline" data-width="300" data-height="650" href="https://twitter.com/LegitReviews?ref_src=twsrc%5Etfw">Tweets by LegitReviews</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> 
    </div>

    <br/>



    <div id="BelowFoldAds">
           
    </div>
    
    <div id="SidebarWidgetTwo">
        </div>
    
    <div id="SidebarWidgetThree">
        </div>




</div>
<div class="clear"></div>
	</div><!-- end main-wrap -->
</div><!-- end page-wrap -->
<div id="footer-wrap">
		<div id="footer">
			<div id="footer-explore">
				<h3>Explore</h3>
<div class="menu-footer-menu-1-container"><ul><li id="menu-item-22159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://www.legitreviews.com/editorial">Editorial</a></li>
<li id="menu-item-22160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://www.legitreviews.com/events">Events</a></li>
<li id="menu-item-22161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://www.legitreviews.com/interviews">Interviews</a></li>
<li id="menu-item-22162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://www.legitreviews.com/news">News</a></li>
<li id="menu-item-22164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22164"><a href="https://forums.legitreviews.com/">Forum</a></li>
<li id="menu-item-22189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22189"><a href="https://amzn.to/2yfyEhP">Shop</a></li>
</ul></div>			</div><!-- end footer-explore -->
			<div id="footer-content">
				<h3>Content</h3>
<div class="menu-footer-menu-2-container"><ul><li id="menu-item-22170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22170"><a href="https://www.legitreviews.com/bluetooth">Bluetooth</a></li>
<li id="menu-item-22171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22171"><a href="https://www.legitreviews.com/cooling">Cooling</a></li>
<li id="menu-item-22172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22172"><a href="https://www.legitreviews.com/editorial">Editorial</a></li>
<li id="menu-item-22173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22173"><a href="https://www.legitreviews.com/events">Events</a></li>
<li id="menu-item-22174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22174"><a href="https://www.legitreviews.com/interviews">Interviews</a></li>
<li id="menu-item-22175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22175"><a href="https://www.legitreviews.com/memory">Memory</a></li>
<li id="menu-item-22176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22176"><a href="https://www.legitreviews.com/misc">Misc</a></li>
<li id="menu-item-22177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22177"><a href="https://www.legitreviews.com/mobile">Mobile</a></li>
<li id="menu-item-22178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22178"><a href="https://www.legitreviews.com/mods_and_ends">Mods and Ends</a></li>
<li id="menu-item-22179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22179"><a href="https://www.legitreviews.com/motherboards">Motherboards</a></li>
<li id="menu-item-22180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22180"><a href="https://www.legitreviews.com/news">News</a></li>
<li id="menu-item-22181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22181"><a href="https://www.legitreviews.com/pc-cases">PC Cases</a></li>
<li id="menu-item-22182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22182"><a href="https://www.legitreviews.com/power_supply">Power Supply</a></li>
<li id="menu-item-22183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22183"><a href="https://www.legitreviews.com/press-releases">Press Releases</a></li>
<li id="menu-item-22184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22184"><a href="https://www.legitreviews.com/processors">Processors</a></li>
<li id="menu-item-22185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22185"><a href="https://www.legitreviews.com/reviews">Reviews</a></li>
<li id="menu-item-22186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22186"><a href="https://www.legitreviews.com/storage">Storage</a></li>
<li id="menu-item-22187" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22187"><a href="https://www.legitreviews.com/video-cards">Video Cards</a></li>
</ul></div>
			</div><!-- end footer-content -->
			<div id="footer-about">
				<h3>About</h3>
<div class="menu-footer-menu-3-container"><ul><li id="menu-item-22166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22166"><a href="https://www.legitreviews.com/contact-us">Contact Us</a></li>
<li id="menu-item-22167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22167"><a href="https://www.legitreviews.com/disclaimer">Disclaimer</a></li>
<li id="menu-item-22169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22169"><a href="https://www.legitreviews.com/about-us">About Us</a></li>
<li id="menu-item-205637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205637"><a href="https://www.legitreviews.com/privacy-policy">Privacy Policy</a></li>
</ul></div>			</div><!-- end footer-about -->
			<div id="lr-footer-social">

        <svg aria-hidden="true" style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
          <defs>
            <symbol id="footer-social-icon-facebook" viewBox="0 0 64 64">
              <title>Facebook</title>
              <path d="M38 12h10v-12h-10c-7.72 0-14 6.28-14 14v6h-8v12h8v32h12v-32h10l2-12h-12v-6c0-1.084 0.916-2 2-2z"></path>
            </symbol>
            <symbol id="footer-social-icon-instagram" viewBox="0 0 64 64">
              <title>Instagram</title>
              <path d="M32 5.763c8.55 0 9.563 0.037 12.925 0.188 3.125 0.138 4.813 0.662 5.938 1.1 1.487 0.575 2.563 1.275 3.675 2.387 1.125 1.125 1.813 2.188 2.4 3.675 0.438 1.125 0.962 2.825 1.1 5.938 0.15 3.375 0.188 4.387 0.188 12.925s-0.038 9.563-0.188 12.925c-0.138 3.125-0.663 4.813-1.1 5.938-0.575 1.487-1.275 2.563-2.388 3.675-1.125 1.125-2.188 1.813-3.675 2.4-1.125 0.438-2.825 0.962-5.938 1.1-3.375 0.15-4.388 0.188-12.925 0.188s-9.563-0.038-12.925-0.188c-3.125-0.138-4.813-0.663-5.938-1.1-1.488-0.575-2.563-1.275-3.675-2.388-1.125-1.125-1.813-2.188-2.4-3.675-0.438-1.125-0.963-2.825-1.1-5.938-0.15-3.375-0.188-4.388-0.188-12.925s0.037-9.563 0.188-12.925c0.138-3.125 0.662-4.813 1.1-5.938 0.575-1.488 1.275-2.563 2.388-3.675 1.125-1.125 2.188-1.813 3.675-2.4 1.125-0.438 2.825-0.963 5.938-1.1 3.363-0.15 4.375-0.188 12.925-0.188zM32 0c-8.688 0-9.775 0.037-13.188 0.188-3.4 0.15-5.738 0.7-7.762 1.488-2.113 0.825-3.9 1.913-5.675 3.7-1.788 1.775-2.875 3.563-3.7 5.662-0.787 2.037-1.337 4.362-1.488 7.763-0.15 3.425-0.188 4.512-0.188 13.2s0.037 9.775 0.188 13.188c0.15 3.4 0.7 5.737 1.488 7.763 0.825 2.112 1.913 3.9 3.7 5.675 1.775 1.775 3.562 2.875 5.663 3.688 2.037 0.788 4.363 1.337 7.762 1.487 3.413 0.15 4.5 0.188 13.188 0.188s9.775-0.038 13.187-0.188c3.4-0.15 5.737-0.7 7.763-1.487 2.1-0.813 3.888-1.913 5.663-3.688s2.875-3.563 3.688-5.663c0.788-2.038 1.337-4.362 1.487-7.763 0.15-3.413 0.188-4.5 0.188-13.188s-0.038-9.775-0.188-13.188c-0.15-3.4-0.7-5.738-1.487-7.762-0.788-2.125-1.875-3.912-3.663-5.688-1.775-1.775-3.563-2.875-5.663-3.688-2.038-0.787-4.362-1.337-7.763-1.488-3.425-0.163-4.513-0.2-13.2-0.2v0z"></path>
              <path d="M32 15.563c-9.075 0-16.438 7.363-16.438 16.438s7.363 16.438 16.438 16.438 16.438-7.362 16.438-16.438c0-9.075-7.362-16.438-16.438-16.438zM32 42.663c-5.887 0-10.663-4.775-10.663-10.663s4.775-10.663 10.663-10.663c5.888 0 10.663 4.775 10.663 10.663s-4.775 10.663-10.663 10.663z"></path>
              <path d="M52.925 14.912c0 2.119-1.718 3.838-3.837 3.838s-3.837-1.718-3.837-3.838c0-2.119 1.718-3.838 3.837-3.838s3.837 1.718 3.837 3.838z"></path>
            </symbol>
            <symbol id="footer-social-icon-twitter" viewBox="0 0 64 64">
              <title>Twitter</title>
              <path d="M64 14.15c-2.35 1.050-4.888 1.75-7.538 2.062 2.712-1.625 4.788-4.2 5.775-7.262-2.538 1.5-5.35 2.6-8.337 3.188-2.4-2.55-5.813-4.138-9.587-4.138-7.25 0-13.125 5.875-13.125 13.125 0 1.025 0.113 2.025 0.337 2.988-10.913-0.55-20.587-5.775-27.063-13.725-1.125 1.938-1.775 4.2-1.775 6.6 0 4.55 2.312 8.575 5.838 10.925-2.15-0.063-4.175-0.663-5.95-1.637 0 0.050 0 0.113 0 0.163 0 6.363 4.525 11.675 10.537 12.875-1.1 0.3-2.262 0.462-3.463 0.462-0.85 0-1.662-0.087-2.475-0.237 1.675 5.212 6.525 9.012 12.262 9.125-4.5 3.525-10.15 5.625-16.313 5.625-1.063 0-2.1-0.063-3.138-0.188 5.825 3.737 12.725 5.9 20.137 5.9 24.15 0 37.362-20.013 37.362-37.362 0-0.575-0.013-1.137-0.038-1.7 2.563-1.837 4.788-4.15 6.55-6.787z"></path>
            </symbol>
            <symbol id="footer-social-icon-rss" viewBox="0 0 64 64">
              <title>RSS</title>
              <path d="M8.518 46.933c-4.7 0-8.518 3.833-8.518 8.505 0 4.697 3.819 8.488 8.518 8.488 4.717 0 8.531-3.791 8.531-8.488-0-4.671-3.814-8.505-8.531-8.505zM0.010 21.746v12.266c7.987 0 15.497 3.123 21.154 8.782 5.649 5.645 8.768 13.19 8.768 21.206h12.32c-0-23.301-18.955-42.254-42.241-42.254zM0.024 0v12.272c28.486 0 51.672 23.208 51.672 51.728h12.303c0-35.279-28.703-64-63.976-64z"></path>
            </symbol>
            <symbol id="footer-social-icon-youtube" viewBox="0 0 64 64">
              <title>YouTube</title>
              <path d="M63.362 19.2c0 0-0.625-4.412-2.55-6.35-2.438-2.55-5.163-2.563-6.413-2.713-8.95-0.65-22.387-0.65-22.387-0.65h-0.025c0 0-13.438 0-22.387 0.65-1.25 0.15-3.975 0.162-6.412 2.713-1.925 1.938-2.538 6.35-2.538 6.35s-0.637 5.175-0.637 10.363v4.85c0 5.175 0.637 10.363 0.637 10.363s0.625 4.413 2.538 6.35c2.438 2.55 5.638 2.462 7.063 2.737 5.125 0.487 21.762 0.638 21.762 0.638s13.45-0.025 22.4-0.663c1.25-0.15 3.975-0.163 6.413-2.712 1.925-1.938 2.55-6.35 2.55-6.35s0.638-5.175 0.638-10.362v-4.85c-0.013-5.175-0.65-10.363-0.65-10.363zM25.387 40.3v-17.988l17.287 9.025-17.288 8.962z"></path>
            </symbol>
          </defs>
        </svg>

        <h3>Follow Us</h3>
        <ul class="footer-social__list">
          <li class="footer-social__item">
            <a href="https://www.facebook.com/LegitReviews" target="_blank" class="footer-social__link footer-social__link--facebook">
              <svg class="footer-social__icon" focusable="false" aria-label="Facebook"><use xlink:href="#footer-social-icon-facebook"></use></svg>
            </a>
          </li>
          <li class="footer-social__item">
            <a href="https://twitter.com/legitreviews" target="_blank" class="footer-social__link footer-social__link--twitter">
              <svg class="footer-social__icon" focusable="false" aria-label="Twitter"><use xlink:href="#footer-social-icon-twitter"></use></svg>
            </a>
          </li>
          <li class="footer-social__item">
            <a href="https://www.instagram.com/legitreviews/" target="_blank" class="footer-social__link footer-social__link--instagram">
              <svg class="footer-social__icon" focusable="false" aria-label="Instagram"><use xlink:href="#footer-social-icon-instagram"></use></svg>
            </a>
          </li>
          <li class="footer-social__item">
            <a href="https://www.youtube.com/user/legitreview/" target="_blank" class="footer-social__link footer-social__link--youtube">
              <svg class="footer-social__icon" focusable="false" aria-label="YouTube"><use xlink:href="#footer-social-icon-youtube"></use></svg>
            </a>
          </li>
          <li class="footer-social__item">
            <a href="https://www.legitreviews.com/feed" class="footer-social__link footer-social__link--rss">
              <svg class="footer-social__icon" focusable="false" aria-label="RSS Feed"><use xlink:href="#footer-social-icon-rss"></use></svg>
            </a>
          </li>
        </ul>

			</div><!-- end footer-social -->
			<div class="clear"></div>
			<div id="footer-info"><span>Copyright &copy; 2002-2020 LegitReviews.com -- All Rights Reserved.</span></div><!-- end footer-info -->
			<div class="clear"></div>
		</div><!-- end footer -->
	</div><!-- end footer-wrap -->
        </div>
	<div id="wallpaper-overlay-container">&nbsp;</div>
        <script type="text/javascript">
            // Define template folder for later use in jQuery to set background image via DFP
            var templateDir = "https://www.legitreviews.com/wp-content/themes/Legitreviews";
        </script>
    
		<div id='acm-ad-tag-Site-Wallpaper' style='width:1px; height:1px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-Site-Wallpaper'); });
</script>
		</div>
			<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ccfSettings = {"ajaxurl":"https:\/\/www.legitreviews.com\/wp-admin\/admin-ajax.php","required":"This field is required.","date_required":"Date is required.","hour_required":"Hour is required.","minute_required":"Minute is required.","am-pm_required":"AM\/PM is required.","match":"Emails do not match.","email":"This is not a valid email address.","recaptcha":"Your reCAPTCHA response was incorrect.","recaptcha_theme":"light","phone":"This is not a valid phone number.","digits":"This phone number is not 10 digits","hour":"This is not a valid hour.","date":"This date is not valid.","minute":"This is not a valid minute.","fileExtension":"This is not an allowed file extension","fileSize":"This file is bigger than","unknown":"An unknown error occured.","website":"This is not a valid URL. URL's must start with http(s):\/\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/assets/build/js/form.min.js?ver=7.8.5'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.carouFredSel-6.2.1-packed.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.touchSwipe.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.colorbox-min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/script-2.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/mobile-7462caa84ebd318823cf6c5237bb5842.min.js?ver=4.9.8'></script>
<link rel='stylesheet' id='ccf-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='ccf-form-css'  href='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/assets/build/css/form.min.css?ver=7.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css'  href='https://www.legitreviews.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.38' type='text/css' media='all' />
<link rel='stylesheet' id='colorboxcss-css'  href='https://www.legitreviews.com/wp-content/themes/Legitreviews/css/colorbox.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.legitreviews.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<script type='text/javascript' src='//www.google.com/recaptcha/api.js?ver=7.8.5&#038;onload=ccfRecaptchaOnload&#038;render=explicit'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"legit"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"223923 http:\/\/www.legitreviews.com\/?p=223923","disqusShortname":"legit","disqusTitle":"XFX Speedster MERC319 Radeon RX 6800 XT Review","disqusUrl":"https:\/\/www.legitreviews.com\/xfx-speedster-merc319-radeon-rx-6800-xt-review_223923","postId":"223923"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WP_API_Settings = {"root":"https:\/\/www.legitreviews.com\/wp-json\/","nonce":"64a56c206d"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/wp-api/wp-api.js?ver=1.2'></script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1196343-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1196343-1');
</script>

	<!---VibrantMedia AdTag Start -->

	<!---VibrantMedia AdTag End -->


</body>

</html>
