<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="https://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">

    <head profile="https://gmpg.org/xfn/11">

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

	    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

        
        <link rel="shortcut icon" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/favicon.ico" type="image/x-icon" />

        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Chivo" />

        	    <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/style-72c1d59eb44bf8ea9d8542ecffdc620c.min.css" type="text/css" />

        <!--[if IE 7]>
        <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/style_ie7.css" type="text/css" />
        <![endif]-->

        <!--[if gte IE 8]>
        <link rel="stylesheet" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/style_ie8.css" type="text/css" />
        <![endif]-->

        <link rel="pingback" href="https://www.legitreviews.com/xmlrpc.php" />

                    <link rel="image_src" type="image/jpeg" href="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/default_like.jpg" />
            


        <script type="text/javascript">
            (function() {
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            })();
        </script>

        
        
<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="During CES 2020 the Plextor M9P Plus PCIe 3.0 x4 NVMe M.2 RGB SSD series was announced. These drives use the Marvell 88SS1092 &#039;Eldora Plus&#039; controller."/>
<meta name="news_keywords" content="96-layer nand flash, bics4, m9p+ m9p plus, m9pg+, marvell 88ss1092, plextor, technology, computing" />
<meta name="original-source" content="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741" />
<link rel="canonical" href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741" />
<link rel="next" href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/2" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Plextor M9P Plus M.2 1TB SSD Review - Legit Reviews" />
<meta property="og:description" content="During CES 2020 the Plextor M9P Plus PCIe 3.0 x4 NVMe M.2 RGB SSD series was announced. These drives use the Marvell 88SS1092 &#039;Eldora Plus&#039; controller." />
<meta property="og:url" content="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741" />
<meta property="og:site_name" content="Legit Reviews" />
<meta property="article:tag" content="96-layer NAND Flash" />
<meta property="article:tag" content="BiCS4" />
<meta property="article:tag" content="M9P+ M9P Plus" />
<meta property="article:tag" content="M9PG+" />
<meta property="article:tag" content="Marvell 88SS1092" />
<meta property="article:tag" content="Plextor" />
<meta property="article:section" content="Storage" />
<meta property="article:published_time" content="2020-01-13T16:24:29+00:00" />
<meta property="article:modified_time" content="2020-01-13T16:54:28+00:00" />
<meta property="og:updated_time" content="2020-01-13T16:54:28+00:00" />
<meta property="og:image" content="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd.jpg" />
<meta property="og:image:secure_url" content="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="646" />
<meta property="og:image:alt" content="Plextor M9P Plus M.2 NVMe SSD" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; Feed" href="https://www.legitreviews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; Comments Feed" href="https://www.legitreviews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Legit Reviews &raquo; Plextor M9P Plus M.2 1TB SSD Review Comments Feed" href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.legitreviews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='https://api.w.org/' href='https://www.legitreviews.com/wp-json/' />
<link rel='shortlink' href='https://www.legitreviews.com/?p=216741' />
<link rel="alternate" type="application/json+oembed" href="https://www.legitreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.legitreviews.com%2Fplextor-m9p-plus-m-2-1tb-ssd-review_216741" />
<link rel="alternate" type="text/xml+oembed" href="https://www.legitreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.legitreviews.com%2Fplextor-m9p-plus-m-2-1tb-ssd-review_216741&#038;format=xml" />
	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/4042371/Top_Leaderboard_Banner', [728,90], "acm-ad-tag-Top_Leaderboard_Banner").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right_Top_Half_Page', [300,600], "acm-ad-tag-Right_Top_Half_Page").addService(googletag.pubads());
googletag.defineSlot('/4042371/Left-Skyscraper-Above', [160,600], "acm-ad-tag-Left-Skyscraper-Above").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right-Skyscraper-Above', [160,600], "acm-ad-tag-Right-Skyscraper-Above").addService(googletag.pubads());
googletag.defineSlot('/4042371/Left-Skyscraper-Below', [160,600], "acm-ad-tag-Left-Skyscraper-Below").addService(googletag.pubads());
googletag.defineSlot('/4042371/Right-Skyscraper-Below', [160,600], "acm-ad-tag-Right-Skyscraper-Below").addService(googletag.pubads());
googletag.defineSlot('/4042371/Site-Wallpaper', [1,1], "acm-ad-tag-Site-Wallpaper").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

        
        <title>
            Plextor M9P Plus M.2 1TB SSD Review - Legit ReviewsPlextor M9P+ 1TB Drive Review in Model M9PG+        </title>

    </head>

    <body class="post-template-default single single-post postid-216741 single-format-standard">
        <div id="wrapper">
        <div id="page-wrap">

            <div id="header">
                <a href="https://www.legitreviews.com" id="logo" class="ir">&nbsp;</a>

                <div id="header-banner">
                                    </div>
                <div class="clear"></div>

	            <div class="main-navigation" role="navigation">

		            <button type="button" class="main-navigation__toggle js-main-navigation-toggle" aria-hidden="true" aria-owns="main-navigation__container" aria-controls="main-navigation__container" aria-haspopup="true" aria-label="Navigation Toggle" aria-pressed="false"></button>

		            <div id="main-navigation__container" class="main-navigation__container js-main-navigation" aria-hidden="false" tabindex="0">

	                <div id="header-menu" class="menu-header-categories-menu-container"><ul id="menu-header-categories-menu" class="main-menu-header"><li id="menu-item-22140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22140"><a href="https://www.legitreviews.com/processors">Processors</a></li>
<li id="menu-item-22139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22139"><a href="https://www.legitreviews.com/pc-cases">PC Cases</a></li>
<li id="menu-item-22142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22142"><a href="https://www.legitreviews.com/video-cards">Video Cards</a></li>
<li id="menu-item-22137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22137"><a href="https://www.legitreviews.com/motherboards">Motherboards</a></li>
<li id="menu-item-22141" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22141"><a href="https://www.legitreviews.com/storage">Storage</a></li>
<li id="menu-item-22136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22136"><a href="https://www.legitreviews.com/mobile">Mobile</a></li>
<li id="menu-item-22134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22134"><a href="https://www.legitreviews.com/memory">Memory</a></li>
<li id="menu-item-22133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22133"><a href="https://www.legitreviews.com/cooling">Cooling</a></li>
<li id="menu-item-22135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22135"><a href="https://www.legitreviews.com/misc">Misc</a></li>
<li id="menu-item-22138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22138"><a href="https://www.legitreviews.com/news">News</a></li>
</ul></div>
	                <div class="clear"></div>

		                <div id="header-submenu">
		                    <ul>
		                        <li><a href="https://www.legitreviews.com" class="submenu-home submenu-a">Home</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://forums.legitreviews.com/" class="submenu-forum submenu-a" >Forum</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://amzn.to/2zbZTs5" class="submenu-shop submenu-a" >Shop</a></li>
		                        <li><span class="header-submenu-sep">|</span></li>
		                        <li><a href="https://www.legitreviews.com/feed" class="submenu-rss submenu-a" >RSS</a></li>
		                    </ul>
		                </div><!-- end header-submenu-->

		            </div><!-- .main-navigation__container -->

	            </div><!-- .main-navigation -->

	            <div class="header-submenu-search">
                    <form method="get" id="searchform" name="searchform" action="https://www.legitreviews.com/gsearch">
                        <input type="text" name="q" id="gs" class="search-input" placeholder="Search Legit Reviews" />
                        <button type="submit" id="searchsubmit" form="searchform"><span class="search-button__icon ir">Search</span></button>
                        <!-- <input type="image" id="searchsubmit" src="https://www.legitreviews.com/wp-content/themes/Legitreviews/images/search_btn.png" alt="Search" /> -->
                    </form>
                </div>

                <div class="clear"></div>
            </div><!-- end header -->
            <div id="main-wraper">

<div class="main">

	<div class="breadcrumbs">
		<!-- Breadcrumb NavXT 6.2.1 -->
<a title="Go to Legit Reviews." href="https://www.legitreviews.com">Legit Reviews</a><span class="bredcrumbs-sep">&nbsp;</span><span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Reviews category archives." href="https://www.legitreviews.com/reviews" class="taxonomy category"><span property="name">Reviews</span></a><meta property="position" content="2"></span><span class="bredcrumbs-sep">&nbsp;</span>Plextor M9P Plus M.2 1TB SSD Review	</div>
	<div class="sub-main ">

		<h2>Plextor M9P Plus M.2 1TB SSD Review</h2>
	
	<div class="main-content-article-author-single">
		Posted by <span class="author-span">Nathan Kirsch</span> 		<span class="header-submenu-table-sep">|</span> Mon, Jan 13, 2020 - 10:24 AM
		
		<div class="wrap-comments-single">
                    	</div>
	
		<div style="clear: both"></div>
	</div>
		<div class="article-social"> 	
		<div class="pw-widget pw-counter-horizontal pw-horizontal ra1-pw-widget-looknative ra1-pw-layout-horizontal ra1-pw-counter-horizontal pw-size-medium" pw:url="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741" pw:title="Plextor M9P Plus M.2 1TB SSD Review" pw:counter="show" style="display:inline;">
			<a class="pw-button-email" pw:counter="false"></a>
			<a class="pw-button-facebook" pw:counter="true"></a>
			<a class="pw-button-twitter" pw:counter="true"></a>
			<a class="pw-button-googleplus" pw:counter="true"></a>
			<a class="pw-button-post"></a>
		</div>
	</div>
		
	<div style="clear:both"></div>
	
	
		<div class="single-pagination-wrap">
			<span class="jump-to">Jump To:</span>
			<select onchange="location.href=this.value">
<option value="" selected="selected">Page 1: Plextor M9P+ 1TB Drive Review in Model M9PG+</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/2">Page 2: The SSD Benchmark Test System</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/3">Page 3: Anvil Storage Utilities</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/4">Page 4: ATTO &amp; CrystalDiskMark</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/5">Page 5: AS SSD Benchmark</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/6">Page 6: AJA System Test and PCMark 8</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/7">Page 7: File Transfer, File Read and Document Open</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/8">Page 8: Game Load Time Testing</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/9">Page 9: Final Thoughts &amp; Conclusions</option>
			</select>
		</div><!-- end single-pagination-wrap -->
		<div class="clear"></div>
	
                <div class="main-content-article-div">
                    <p><!--pagetitle:Plextor M9P+ 1TB Drive Review in Model M9PG+--></p>
<h3>Plextor M9P+ 1TB Drive Review in Model M9PG+</h3>
<p>During CES 2020 the Plextor M9P Plus PCIe 3.0 x4 NVMe M.2 RGB SSD series was announced. These drives use the Marvell 88SS1092 &#8216;Eldora Plus&#8217; 8-channel controller that has been paired with the latest BiCS4 96-layer TLC NAND Flash. The pairing creates a drive capable of reaching sequential speeds of up to 3,400 MB/s read and 2,200 MB/s write. With regards to Random 4K performance you are looking at up to 340,000 IOPS Read and 300,000 IOPS Write.</p>
<p>These performance numbers are not the highest out there, but Plextor believes they have a winner here for PC gamers and prosumers that are looking for the ultimate user experience.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd.jpg"><img class="aligncenter size-large wp-image-216766" src="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-645x347.jpg" alt="Plextor M9P Plus M.2 NVMe SSD" width="645" height="347" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-645x347.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-140x75.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-300x162.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-768x413.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd-195x105.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-nvme-ssd.jpg 1200w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>The drive that we were sent out to review was the Plextor M9P Plus 1TB SSD (M9PG+) that has an MSRP of $134.99. There are three versions of the Plextor M9P Plus available in two form factors (AIC/HHHL &amp; M.2) in capacities of 256GB, 512GB and 1TB.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives.jpg"><img class="aligncenter size-full wp-image-216769" src="https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives.jpg" alt="Plextor M9P Plus Drives" width="454" height="395" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives.jpg 454w, https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives-140x122.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives-300x261.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/m9p-plus-drives-195x170.jpg 195w" sizes="(max-width: 454px) 100vw, 454px" /></a></p>
<p>The lowest prices version of the M9P+ would be the M8PGN+ that comes in the M.2 form factor without any heatsink. For an extra $5-$6 you can move up to the M9PG+ M.2 form factor drive that comes with the heatsink. Those looking for a HHHL Add-in-Card (AIC) should look at the M9PY+ model series that costs an additional $10-$16.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus.png"><img class="aligncenter size-full wp-image-216768" src="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus.png" alt="Plextor M9P+ Pricing" width="549" height="257" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus.png 549w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-140x66.png 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-300x140.png 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-195x91.png 195w" sizes="(max-width: 549px) 100vw, 549px" /></a></p>
<p>&nbsp;</p>
<p>All of the Plextor M9P+ series drives are backed by a 5-year warranty and have an endurance rating of 160 TBW for every 256GB of storage capacity. That means you are looking at 640 TBW for the 1TB model and that comes out to being about 350.6 GB drive writes per day over the course of five years.</p>
<h3>Plextor M9P Plus ( M9PG+) Series Specifications</h3>
<table style="border-collapse: collapse; width: 63.9349%; height: 264px;" border="1">
<tbody>
<tr style="height: 48px;">
<td style="width: 20%; height: 48px;"></td>
<td style="width: 20%; height: 48px;">256GB</td>
<td style="width: 20%; height: 48px;">512GB</td>
<td style="width: 20%; height: 48px;">1TB</td>
</tr>
<tr>
<td style="width: 20%;">Controller</td>
<td style="width: 20%;">Marvell 88SS1092</td>
<td style="width: 20%;">Marvell 88SS1092</td>
<td style="width: 20%;">Marvell 88SS1092</td>
</tr>
<tr>
<td style="width: 20%;">3D NAND Flash</td>
<td style="width: 20%;">BiCS4 96-Layer TLC</td>
<td style="width: 20%;">BiCS4 96-Layer TLC</td>
<td style="width: 20%;">BiCS4 96-Layer TLC</td>
</tr>
<tr style="height: 24px;">
<td style="width: 20%; height: 24px;">Sequential Read (MB/s)</td>
<td style="width: 20%; height: 24px;">3,400</td>
<td style="width: 20%; height: 24px;">3,400</td>
<td style="width: 20%; height: 24px;">3,400</td>
</tr>
<tr style="height: 24px;">
<td style="width: 20%; height: 24px;">Sequential Write (MB/s)</td>
<td style="width: 20%; height: 24px;">1,700</td>
<td style="width: 20%; height: 24px;">2,200</td>
<td style="width: 20%; height: 24px;">2,200</td>
</tr>
<tr style="height: 48px;">
<td style="width: 20%; height: 48px;">Random 4K Read IOPS</td>
<td style="width: 20%; height: 48px;">300,000</td>
<td style="width: 20%; height: 48px;">340,000</td>
<td style="width: 20%; height: 48px;">340,000</td>
</tr>
<tr style="height: 48px;">
<td style="width: 20%; height: 48px;">Random 4K Write IOPS</td>
<td style="width: 20%; height: 48px;">300,000</td>
<td style="width: 20%; height: 48px;">320,000</td>
<td style="width: 20%; height: 48px;">320,000</td>
</tr>
<tr style="height: 24px;">
<td style="width: 20%; height: 24px;">DRAM Cache</td>
<td style="width: 20%; height: 24px;">DDR4</td>
<td style="width: 20%; height: 24px;">DDR4</td>
<td style="width: 20%; height: 24px;">DDR4</td>
</tr>
<tr style="height: 24px;">
<td style="width: 20%; height: 24px;">TBW (Endurance)</td>
<td style="width: 20%; height: 24px;">160 TB</td>
<td style="width: 20%; height: 24px;">320 TB</td>
<td style="width: 20%; height: 24px;">640 TB</td>
</tr>
<tr style="height: 24px;">
<td style="width: 20%; height: 24px;">MSRP  (1/13/20)</td>
<td style="width: 20%; height: 24px;"><a href="https://amzn.to/2QR1LkN" target="_blank" rel="nofollow noopener">$50.99</a></td>
<td style="width: 20%; height: 24px;"><a href="https://amzn.to/2QR1LkN" rel="nofollow">$80.99</a></td>
<td style="width: 20%; height: 24px;"><a href="https://amzn.to/2QR1LkN" target="_blank" rel="nofollow noopener">$134.99</a></td>
</tr>
</tbody>
</table>
<p>The M9P Plus SSD Series features Plextor&#8217;s signature heatsink that is designed to keep the drive under 65C to keep it from ever throttle due to thermals and also improves the aesthetics.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd.jpg"><img class="aligncenter size-large wp-image-216767" src="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-645x243.jpg" alt="Plextor M9P+ 1TB SSD" width="645" height="243" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-645x243.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-140x53.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-300x113.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-768x290.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd-195x74.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-ssd.jpg 1000w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>Plextor uses the standard M.2 2280 &#8216;gum stick&#8217; form factor, but we noticed that the heat spreader wraps around to the back. Clearly this drive is not aimed at laptop users due to the size of the heatsink, so laptop users will want to save a few bucks and get the M8PGN+ version of this drive without the heatsink.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back.jpg"><img class="aligncenter size-large wp-image-216765" src="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-645x249.jpg" alt="Plextor M9P+ 1TB SSD Heatsink" width="645" height="249" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-645x249.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-140x54.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-300x116.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-768x296.jpg 768w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back-195x75.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextor-m9p-plus-back.jpg 1000w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>When it comes to software for the Plextor M9P Plus you can download Plextool NVMe version 2.0.0 from May 2018 as it appears to still work. This gives you the drives general health, SMART details, the ability to secure erase and detailed drive information. You can&#8217;t update the firmware with this utility, but Plextor does release firmware updates via EXE files if they are needed.</p>
<p><a href="https://www.legitreviews.com/wp-content/uploads/2020/01/plextool.jpg"><img class="aligncenter size-large wp-image-216776" src="https://www.legitreviews.com/wp-content/uploads/2020/01/plextool-645x370.jpg" alt="Plextool NVMe" width="645" height="370" srcset="https://www.legitreviews.com/wp-content/uploads/2020/01/plextool-645x370.jpg 645w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextool-140x80.jpg 140w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextool-300x172.jpg 300w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextool-195x112.jpg 195w, https://www.legitreviews.com/wp-content/uploads/2020/01/plextool.jpg 766w" sizes="(max-width: 645px) 100vw, 645px" /></a></p>
<p>That all said, let&#8217;s take a look at some benchmark numbers on our Intel Z390 test platform.</p>
                                        <div class="clear"></div>
                
	
	
	
		<div class="single-pagination-wrap">
			<span class="jump-to">Jump To:</span>
			<select onchange="location.href=this.value">
<option value="" selected="selected">Page 1: Plextor M9P+ 1TB Drive Review in Model M9PG+</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/2">Page 2: The SSD Benchmark Test System</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/3">Page 3: Anvil Storage Utilities</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/4">Page 4: ATTO &amp; CrystalDiskMark</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/5">Page 5: AS SSD Benchmark</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/6">Page 6: AJA System Test and PCMark 8</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/7">Page 7: File Transfer, File Read and Document Open</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/8">Page 8: Game Load Time Testing</option>
<option value="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/9">Page 9: Final Thoughts &amp; Conclusions</option>
			</select>
		</div><!-- end single-pagination-wrap -->
		<div class="clear"></div>
<div class="single-pagination-numbers jump-bottom"> <span class="pag-text">1</span> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/2"><span class="pag-text">2</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/3"><span class="pag-text">3</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/4"><span class="pag-text">4</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/5"><span class="pag-text">5</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/6"><span class="pag-text">6</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/7"><span class="pag-text">7</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/8"><span class="pag-text">8</span></a> <a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/9"><span class="pag-text">9</span></a>&nbsp<a href="https://www.legitreviews.com/plextor-m9p-plus-m-2-1tb-ssd-review_216741/2"><span class="pag-text"> Next &raquo;</span></a></div>
                <div class="clear" style="height: 10px;"></div>

<div id="amzn-assoc-ad-9f0a4c64-a478-47df-ac7f-057273f04ab3"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=9f0a4c64-a478-47df-ac7f-057273f04ab3"></script>

	</div>
	                
                
	</div><!-- end sub-main -->	

	<div id="comments">
<div id="disqus_thread"></div>
</div>

	
	
</div><!-- end main -->

<div id="sidebar">

        
    <div id="SidebarWidgetOne">
        </div>

    <div id="twitter-box">
        <a class="twitter-timeline"  href="https://twitter.com/LegitReviews"  data-widget-id="329830301029244928">Tweets by @LegitReviews</a>
        <script async>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
    </div>

    <br/>



    <div id="BelowFoldAds">
           
    </div>
    
    <div id="SidebarWidgetTwo">
        </div>
    
    <div id="SidebarWidgetThree">
        </div>




</div>
<div class="clear"></div>
	</div><!-- end main-wrap -->
</div><!-- end page-wrap -->
<div id="footer-wrap">
		<div id="footer">
			<div id="footer-explore">
				<h3>Explore</h3>
<div class="menu-footer-menu-1-container"><ul><li id="menu-item-22159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://www.legitreviews.com/editorial">Editorial</a></li>
<li id="menu-item-22160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://www.legitreviews.com/events">Events</a></li>
<li id="menu-item-22161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://www.legitreviews.com/interviews">Interviews</a></li>
<li id="menu-item-22162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://www.legitreviews.com/news">News</a></li>
<li id="menu-item-22164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22164"><a href="https://forums.legitreviews.com/">Forum</a></li>
<li id="menu-item-22189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22189"><a href="https://amzn.to/2yfyEhP">Shop</a></li>
</ul></div>	
			</div><!-- end footer-explore -->
			<div id="footer-content">
				<h3>Content</h3>
<div class="menu-footer-menu-2-container"><ul><li id="menu-item-22170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22170"><a href="https://www.legitreviews.com/bluetooth">Bluetooth</a></li>
<li id="menu-item-22171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22171"><a href="https://www.legitreviews.com/cooling">Cooling</a></li>
<li id="menu-item-22172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22172"><a href="https://www.legitreviews.com/editorial">Editorial</a></li>
<li id="menu-item-22173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22173"><a href="https://www.legitreviews.com/events">Events</a></li>
<li id="menu-item-22174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22174"><a href="https://www.legitreviews.com/interviews">Interviews</a></li>
<li id="menu-item-22175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22175"><a href="https://www.legitreviews.com/memory">Memory</a></li>
<li id="menu-item-22176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22176"><a href="https://www.legitreviews.com/misc">Misc</a></li>
<li id="menu-item-22177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22177"><a href="https://www.legitreviews.com/mobile">Mobile</a></li>
<li id="menu-item-22178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22178"><a href="https://www.legitreviews.com/mods_and_ends">Mods and Ends</a></li>
<li id="menu-item-22179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22179"><a href="https://www.legitreviews.com/motherboards">Motherboards</a></li>
<li id="menu-item-22180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22180"><a href="https://www.legitreviews.com/news">News</a></li>
<li id="menu-item-22181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22181"><a href="https://www.legitreviews.com/pc-cases">PC Cases</a></li>
<li id="menu-item-22182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22182"><a href="https://www.legitreviews.com/power_supply">Power Supply</a></li>
<li id="menu-item-22183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22183"><a href="https://www.legitreviews.com/press-releases">Press Releases</a></li>
<li id="menu-item-22184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22184"><a href="https://www.legitreviews.com/processors">Processors</a></li>
<li id="menu-item-22185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22185"><a href="https://www.legitreviews.com/reviews">Reviews</a></li>
<li id="menu-item-22186" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22186"><a href="https://www.legitreviews.com/storage">Storage</a></li>
<li id="menu-item-22187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22187"><a href="https://www.legitreviews.com/video-cards">Video Cards</a></li>
</ul></div>				
					
			</div><!-- end footer-content -->
			<div id="footer-about">
				<h3>About</h3>
<div class="menu-footer-menu-3-container"><ul><li id="menu-item-22166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22166"><a href="https://www.legitreviews.com/contact-us">Contact Us</a></li>
<li id="menu-item-22167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22167"><a href="https://www.legitreviews.com/disclaimer">Disclaimer</a></li>
<li id="menu-item-22169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22169"><a href="https://www.legitreviews.com/about-us">About Us</a></li>
<li id="menu-item-205637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205637"><a href="https://www.legitreviews.com/privacy-policy">Privacy Policy</a></li>
</ul></div>				
			</div><!-- end footer-about -->
			<div id="footer-social">
				<h3>Follow Us</h3>
				<a href="https://www.facebook.com/pages/Legit-Reviews/47587158881" target="_blank" class="footer-facebook">&nbsp;</a>
				<a href="https://twitter.com/legitreviews" target="_blank" class="footer-twitter">&nbsp</a>
				<a href="https://www.youtube.com/legitreview" target="_blank" class="footer-youtube">&nbsp;</a>
				<a href="https://www.legitreviews.com/feed" class="footer-rss">&nbsp;</a>
			</div><!-- end footer-social -->
			<div class="clear"></div>
			<div id="footer-info"><span>Copyright &copy; 2002-2020 LegitReviews.com -- All Rights Reserved.</span></div><!-- end footer-info -->
			<div class="clear"></div>
		</div><!-- end footer -->
	</div><!-- end footer-wrap -->
        </div>
	<div id="wallpaper-overlay-container">&nbsp;</div>
        <script type="text/javascript">
            // Define template folder for later use in jQuery to set background image via DFP
            var templateDir = "https://www.legitreviews.com/wp-content/themes/Legitreviews";
        </script>
    
		<div id='acm-ad-tag-Site-Wallpaper' style='width:1px; height:1px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-Site-Wallpaper'); });
</script>
		</div>
			<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ccfSettings = {"ajaxurl":"https:\/\/www.legitreviews.com\/wp-admin\/admin-ajax.php","required":"This field is required.","date_required":"Date is required.","hour_required":"Hour is required.","minute_required":"Minute is required.","am-pm_required":"AM\/PM is required.","match":"Emails do not match.","email":"This is not a valid email address.","recaptcha":"Your reCAPTCHA response was incorrect.","recaptcha_theme":"light","phone":"This is not a valid phone number.","digits":"This phone number is not 10 digits","hour":"This is not a valid hour.","date":"This date is not valid.","minute":"This is not a valid minute.","fileExtension":"This is not an allowed file extension","fileSize":"This file is bigger than","unknown":"An unknown error occured.","website":"This is not a valid URL. URL's must start with http(s):\/\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/assets/build/js/form.min.js?ver=7.8.5'></script>
<script type='text/javascript' src='https://i.po.st/static/v3/post-widget.js#publisherKey=qv2cm603l74b7lhtdfr2'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.carouFredSel-6.2.1-packed.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.touchSwipe.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/jquery.colorbox-min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/script.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/themes/Legitreviews/js/mobile-7462caa84ebd318823cf6c5237bb5842.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5c060d570624ce0011ee8aa5'></script>
<script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.legitreviews.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><link rel='stylesheet' id='ccf-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='ccf-form-css'  href='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/assets/build/css/form.min.css?ver=7.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css'  href='https://www.legitreviews.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.38' type='text/css' media='all' />
<link rel='stylesheet' id='colorboxcss-css'  href='https://www.legitreviews.com/wp-content/themes/Legitreviews/css/colorbox.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript' src='//www.google.com/recaptcha/api.js?ver=7.8.5&#038;onload=ccfRecaptchaOnload&#038;render=explicit'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"legit"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"216741 http:\/\/www.legitreviews.com\/?p=216741","disqusShortname":"legit","disqusTitle":"Plextor M9P Plus M.2 1TB SSD Review","disqusUrl":"https:\/\/www.legitreviews.com\/plextor-m9p-plus-m-2-1tb-ssd-review_216741","postId":"216741"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WP_API_Settings = {"root":"https:\/\/www.legitreviews.com\/wp-json\/","nonce":"ba46b7b1a2"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.legitreviews.com/wp-content/plugins/custom-contact-forms/wp-api/wp-api.js?ver=1.2'></script>

	<!---VibrantMedia AdTag Start -->
	
	<!---VibrantMedia AdTag End -->

  
</body>

</html>
