ECS Enables Intel X79 SAS Ports on X79R-AX Motherboard


ECS X79R-AX SAS Ports Working


When the Intel X79 platform was first announced it was supposed to include several features that would be new to the Intel desktop line. One of the features was Serial Attached SCSI (SAS) ports. Unfortunately due to compatibility issues, Intel announced that that feature was no longer included and that feature had been completely disabled within the Intel X79 chipset. The reason for ‘removing’ this feature was because Intel observed the x79 SCU SAS/SATA controller may exhibit one or more random ports with unreliable I/O performance. Now that you have a little bit of background information we proceed to the issue at hand.


Right now we are in the process of finalizing a complete review on the ECS X79R-AX Black Extreme motherboard. This board retails for $259.99 after mail-in rebate and is we should have the full performance review on this board in the next few days. While we were getting our first hands on time with the ECS X79R-AX we noticed something that stood out to us. When we looking over the ECS X79R-AX we noticed that four of the SATA ports were labeled as SAS. Initially we figured that ECS already had the board laid out and the silk screening process already in place when Intel dropped the SAS function from the chipset. To be sure though, we contacted ECS and the responded in an unexpected way, ECS left the SAS ports enabled on the X79R-AX and wants to market them as extra SATA ports. ECS also mentioned that they want to keep this low profile.

ECS doesn’t appear to be keeping this feature too quite as a quick
look at Newegg shows the highlight of the board is that SAS has been

Below you can find their response.

“As to SAS labeled, its because originally Intel was going to support SAS connection on X79 chipset, but they hid this function in the end. However, since our MB layout already designed for this support, we decide to keep it. Due to Intel stopped on the project, so its hard to guarantee 100% compatibility on every SAS device, we have to keep it low profile as just more SATA ports to promote it (even though in our test, most SAS storage are workable on these ports). Its indeed supported by Intel X79 chipset, even though Intel doesnt announce to support either disable the function, the function are still in the chipset…”

ECS sent us over some instructions on how to enable the SAS ports for use with a SATA hard drive and we had to give it a try to see if it would really work.

1. You have change the SCU SATA 6Gb/S Device option from ‘Disable’ to ‘Enabled’ in the BIOS as below.
2. Install the SAS driver that is on our driver disc.


The example send over used Western Digital and Samsung hard drives (WD WD1002FAEX 1TB and SAMSUNG HD321KJ 320GB) with the SAS ports of an ECS X79R-AX/V1.0 motherboard and they showed up working just fine.

ECS X79R-AX Device Manager

The above screenshots are directly from ECS and ECS claims that the SAS ports do work. What’s most interesting about this is that Intel stated that this has been disabled. Last week during CES we were able to sit down with Intel, initially they had said that the function had been soldered off. After a little bit of prodding though, we discovered that the SAS function in fact had not been soldered off. Instead we found that it was left enabled and that Intel asked motherboard companies to not support the feature. According to them, there was an agreement between Intel and the motherboard manufacturers not to enable these ports on Intel X79 motherboards.

ECS X79R-AX SAS Controller Device Installation

Of course we were curious if this would actually work on our end. So, we followed the instructions that ECS provided and gave it our best shot. We stuck our head into the BIOS and enabled the SCU SATA 6Gb/s Device option under the advanced tab within the BIOS and rebooted the machine. Upon entering our Windows 7 build a pop up came up and let us know that the “Device Driver Software was not successfully installed”. Looking at the window we can see that Windows 7 couldn’t find the device driver for the SAS Controller. This wasn’t unexpected, especially since ECS informed us that we would need to install the driver from the installation CD.

ECS X79R-AX SAS Controller Device Installation

We went to the installation CD and navigated our way to the Intel RSTe driver and manually began the install. Went through the usual pop ups for the installation procedure and we were told to reboot the system, so we did.

ECS X79R-AX SAS Controller Device Installation

Once the system was completely booted into Windows 7 we stuck our heads into the Device Manager. Once there we took a look at the installed disk drives and we found our Corsair Force GT SSD that we had plugged into one of the SAS ports was showing up! We then went down to the Storage Controllers and found that the Intel C600 series chipset SAS RAID controller had been successfully installed as well!

ECS X79R-AX SAS Port Performance using CrystalDiskMark

We fired up CrystalDiskMark on the Corsair Force GT SSD on both the SAS ports and the Intel SATA III 6GBps ports so we could see what kind of performance gain/loss we might see.

ECS X79R-AX SAS Port Performance using CrystalDiskMark

Running the Corsair Force GT on the SAS ports we were able to hit an average sequential read speed of 412.8MB/s while the SATA III 6Gbps ports hit 504.2MB/s. The sequential writes were also slower on the SAS ports, 41.5MB/s slower. The SATA III 6Gbps ports hit 306.0MB/s while the SAS ports only hit 264.5MB/s. The 4K read only hit 21.56MB/s on the SAS ports while we saw 32.68MB/s on the SATA III ports. The 4K write showed off the biggest loss of performance losing more than 57% of the performance of the SATA III ports.

Since we typically also run HD Tune 4.61 to test the SATA performance we tried to fire it up as well. For some reason every time that we did we would get the notorious blue screen of death when we tried to launch it. We also fired up CrystalDiskInfo to see the condition of the drive and connection type and it wouldn’t see either of the SSD’s connected to the ECS X79R-AX Intel X79 motherboard. Overall the drive seemed to work fine, we were able to copy files to and from it with out issue. If we were able to run HD Tune and see the drives with CrystalDiskInfo we would have been much more comfortable with using it. Since we weren’t able to use those pieces of software it has us a bit concerned. Intel disabled these ports for a reason and it appears that we are figuring out why.

If you pick up an ECS X79R-AX, I personally wouldn’t count on the functionality of the SAS ports, but if it works for you great! If it doesn’t, you’re up the proverbial creek since it isn’t officially supported. Due to the stability issues that I was seeing these extra ports are not ideal for drive storage, but should do fine with optical drives.

Comments are closed.